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Digital Braiding
To really understand this process, you need to know
the definition of a braid. In graphic terms, it's overlapping zigzags with round corners. This holds true for a
3 strand braid, a 4 strand braid, a 5 strand braid, and a
100 strand braid. The braids can then be converted to
repeatable patterns, and defined as patterns to be used
for brushes. As the braids get more complex, they look The definition of a braid, in graphic terms, a woven zigzag with
round corners. You can see the braid taking shape in the bottom
like pieces of fabric woven on the bias.

of the two images here. This paper will outline the steps and the
process for finishing out the braid.

The first time I sat down to map out a braid, it was
brutally difficult. Even though I did complete what
I had set out to do. Any expert scrutiny would have
called it cheesy. This method came to me quite unexpectedly one day when I was experimenting, I get free
time once in a while. When finished, the object looked
like a deformed 4 strand braid. It took a little thought,
and I was able to adapt the technique for a braid with
any number of strands.
Step 1: Create a new file in illustrator, use the default
letter size. Place a horizontal line on the art board, it
should be 9 inches long, the center coordinates should
be 4.25in X and 5.0in Y. The lines will go outside
the page area, this is acceptable. Place another line at
4.25in X and 6.0in Y. Select both lines, and Control
+ Click the art board (Mac), or right click (Win), and
choose make guides from the pop up menu.

Coordinates 0in X, 6in Y

Coordinates 1in X, 5in Y

Step 2: Make a vertical line 1.5 inches tall, the center
coordinates should be 0in X and 5.5in Y. Press V on
the keyboard to get quick access to the Selection Tool,
press enter, this brings up the Move dialog box, you may
also double click the black arrow. For Position Section of
the dialog box, the value for the Horizontal box should
be 1in/3, the Vertical box should read 0, Distance and
Angle are filled in based on the Horizontal and Vertical A sample of the layout guides for creating a 3-strand braid.
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values, click the copy button. You should see a second
vertical line. To get vertical lines going the width of the
art board, use the Command/Control D keystroke to
repeat the lines until you have enough. If you go one
line over the art board boundaries, it won’t cause any
problems. Select the vertical lines and convert them to
guides. The Pen Tool snaps to the guide intersections
that cross each other like a railroad track, better than
snapping to a point at the end of a guide. Make a new
layer, when you expand the pivot triangle for Layer 1,
you will see that each guide is a sub-layer. It is my prefer- The arrows mark 1 inch increments. The first point is placed at
ence to put artwork on a separate layer from the guides, 0in X and 6in Y, the second point is placed at 1in X and 5in Y.
Zigzag on every third line.
because of this.
Step 3: Use the Pen Tool, place a point on the left side
of the top guide line, 0in X, 6in Y coordinates. Move to
the right, 1 inch, and place a point on the bottom guide
line, 1in X, 5in Y coordinates. Zigzag the line until you
run out of bar guides.
Step 4: Select the zigzag line, if a portion of the line is
selected, it will not transform correctly. Use the Selection Tool (V), and press enter to bring up the dialog box,
input 4p0 for the Horizontal value, and click the copy
button. Use the Command/Control D keystroke to get
a second copy. Even though you may be using inches as
the default ruler scale, you want to move the line 2⁄ 3 of
an inch. The value 4p0 represents 4 picas, 0 points, and
4 picas is 2⁄ 3 of an inch, so without changing your default
ruler units, you can input a value from another unit of
measure and get the desired result.

Yes I’m guilty of a preference to Pica Units. At the same time,
if I need to move an object 3/8 of an inch, I could put a value
of .375in for the Horizontal value, press copy, and it would step
3
⁄8 of an inch. Illustrator is good at handling measurements that
way, InDesign does that as well.

Step 5: Use the Direct Selection Tool (A), and select the
two points to the far left to delete, and the same with
three points on the far right. When the braid is complete, this will give the braid ends a frayed look. Select all
three lines, and from the overhead menu, Filter > Stylize > Round Corners. Input a value of .5in. The Round
Corner value will change the shape of the braid. Higher

The Red arrows point to solid blocks that have been selected
by the Direct Selection Tool. The Green arrows point to hollow
blocks on the same path that have not be selected, the hollow
block are not affected by deleting the selection of solid blocks.
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values for Round Corners gives a narrow and tight braid,
lower values give a wide and loose braid.
Step 6: With the lines still selected, increase the stroke to
27pt. Zoom in, you'll see small white triangles between
the rounded zigzags. If the stroke were increased to 28pt,
the lines would overlap, and the braid process would fail.
If you wish, the stroke value of the lines may be reduced,
giving a loose look to the braid. Object > Expand from
the overhead menu. AI9 users will have to expand the
lines one at a time.

Round Corners Dialog box: Filter > Stylize > Round Corners

Once the corners have been Rounded, increase the Stroke value
to 27 pt. When you zoom in to the document, you should see
small areas of space between the lines. If the space isn’t there, the
braid will fail. The Stroke value can be varied, as long as there
is space between the lines.

Step 7: Open the Pathfinder Palette, and access the palette menu by the right pointing triangle in the upper
right corner. Choose the Pathfinder options from the
menu, and check off the option Divide and Outline
Will Remove Unpainted Artwork. Then click the Divide
option on the Pathfinder Menu. Press D for default
colors, so that you can see the outlines of the pieces
when the segments are deselected.

When the Divide Option is used from the Pathfinder menu, it
creates unpainted paths from empty areas, like the small triangular spaces between the braid lines. Unpainted paths can cause
problems for this project.

Step 8: Expand the pivot triangle on the left side of
Layer 2. Select the artwork, and Object > Ungroup from
the menu (Command/Control +.Shift +G). Ungrouping the artwork allows you to use the Direct Selection
Tool (A) or the Selection Tool (V). Selecting individual
paths from a Group, you need to use the Direct Selection Tool (A). Starting from the top left, select three seg- Grouping the segments by color is a good way to get familiar
ments and change the fill to red. Group the segments with the braid process. This step isn’t critical, it’s a good practice
for getting a look at the final picture.
and double click the group name in the Layers Palette,
rename Red Group. In selecting the next three segments
to group, start from the bottom, where the red is woven
under the next group. Set the fill to green, group, and
rename to Green Group. That leaves a single segment on
the left, select it, follow the weave, and select the next
three segments that come up on the other side of the red
strand. Change color to blue, group, and rename Blue
Group. Follow each strand through the weave, and add
red segments to the Red Group, green segments to the
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Green Group, and blue segments to the Blue Group.
1.
Once all the colors are assigned, you may use the Wand
Tool for grouping, moving the segments into each of the
color groups.
2.

Step 9: Use the Wand Tool and select all the Blue segments. Press Alt, and click Add to Area Shape from the
Pathfinder menu. This will create unite all the paths in 3.
one easy click. Repeat with Red and Green groups. If you
want to apply a style to the segments, ungroup first.
Image 1: United Blue Strand. Image 2: United Red Strand.
Image 3: United Green Strand.

Step 10: Not all braid patterns need to repeat, but for
those that do, here are the steps to follow. Repeating
the pattern. Prepare the pattern by unlocking all the segments. Object > Unlock All. The stroke on the segments
is 1 pt, this can be increased or decreased according to
the individual prefs. I'm going to increase the stroke
to 2 pt. Object > Expand, then Divide from the Path- The stroke was increase to 2 pt, the graphic expanded, and
finder menu. If you expand the layer, you'll notice sev- paths Divided.
eral additional paths. Deselect all paths, select the Wand
tool from the Tool palette. Zoom in, and click on a
black path. The Wand will select all black segments.
Command/Control X to delete. The divide left some The black filled paths were selected and deleted.
small slivered paths around the braid segments. Delete
these too. If you'll click on the right side of the object
bar, you can easily select the unwanted paths to delete.
Shift clicking the path bars will add to the selection.
Step 11: Depending on how the braid is going to look
will depend on how you repeat the pattern. Notice the
three pointers above the braid. From the black pointer
on the left, to the black pointer on the right, indicates
a repeating pattern with each strand a different color.
If you plan to make a braid pattern with a single color,
change the fill on all segments to black then the repeat
would be from the black left pointer to the red pointer.
It's no accident that the pattern can be sliced according
to the vertical guides. The purple pointer below the
braid pattern points at the first green segment. The angle

Notice that the guides make natural markers to help you determine the length of the repeating pattern. I’ll admit to using
a brush stroke for placing pointers. I could have used small
circles or blocks. Because this pattern was based on AI Math, the
pattern is twice the distance of two guidelines. The distance of 6
guidelines for a multicolored braid.
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on this first segment will not align as a repeating pattern, due to it's angle. Put a marker, small circle, over
the guides you're planning to use to mark your repeating pattern. Until you are familiar with the process, this
will be helpful. Use the Line Tool, and place a vertical
line over the guide under the black pointer on the left,
then do the same with the black pointer on the right.
The lines have to be straight or the pattern will not line
up. Select the lines and the braid, click Divide from the
Pathfinder Palette. Use the Direct Selection Tool (A),
and select segments left of the black marker on the left,
and segments to the right of the right marker. Shown
multicolored braid
single color braid
are the repeating patterns for a single color braid, and a The repeating segments of the braid strand are shown. The
3-strand segment could be set up as a single color. A single
three color braid.
segment, like the one on the right, cannot be set up as a
multi-colored strand.

Step 12: Select the Braid segment, Edit >Define Pattern
from the overhead menu. Open the Brush Palette and
make a new pattern brush. Experiment with the color
settings on the Pattern Brush Dialog box.

Select the colored strand, Edit > Define Pattern, name it colored
braid. Then from the Brush Palette, click the New Brush icon,
and select Pattern Brush from the options. Select the pattern
from the list. Only the straight segment of the brush needs to be
defined. The frayed edges can be defined as patterns for the start
and finish of the brush strokes. For Colorization, I chose Tints
and Shades, experiment with the different color settings.
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Step 13: Test the brush, by making a new layer and
placing a circle, a hexagon and a square on the new
layer. The square and the hexagon will not have corners
when the brush is applied. The corners will need to be
rounded to get the braid to connect around the corners. The math involved in making a corner brush for
a braid hasn't presented itself at this time. Corners can
be rounded by either of these methods, Filter > Stylize >
Round Corners or Effect > Stylize > Round Corners. You
may want to use an Effect here, so that you can modify
the Round Corners value without changing the path.
Depending on how well the corners line up, depends on
the Round Corner value, and the Stroke value on the
path you're stroking. If you open the Stroke palette, and
enter a value of .5 for the stroke, the width of the brush
stroke will decrease.

Tints and Shades Color Option
Stroke value 1

Tints Colorization Option
Stroke value .5
Round Corner value 48 pt

Hue Shift Color Option
Stroke value .25
Round Corner value 12 pt
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Notes: Even on a circle path, there will be some brush
distortion, it is a natural phenomenon for real braids.
Some sample images on setting up a 4, 5 and 6 strand
braid here. Specialized brush strokes can be used to
add unique properties to the strands, if you can't get
a repeating pattern, make one long strand for your artwork. The limiting factors here, will be what you decide
can and can not be done. Also shown are samples based
on the braid template set up in this document, they
were varied by Stroke weight, Round Corner input, and The spacing of the guides may vary. The step value for a zigzag
Brush strokes.
line will be twice the distance of two guides. The 4 strand braid
was set up on a ¼ inch grid, the 5 strand on a 1⁄5 inch grid and
the 6 strand on 1⁄6 inch grid. The Round Corner value is variable,
and don’t be afraid to experiment. A higher Round Corner value
will give a result similare to Sample 1, below. A lower value will
give a result similar to Sample 2, below.

The samples here are based on the grid set up for the tutorial,
3 guides per inch. the Stroke/Round Corner options varied for
samples 1, 2 &3. Sample 4 is an example of a non-repeating
braid made from the same grid. Each strand had a custom
brush applied, the brush strokes were expanded, and the strands
divided the same way the other patterns were created. So be
creative and get artzy.
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